Friday, August 05, 2011

Greasemonkey Usage by Firefox Version, August 2011

I'm revisiting the Greasemonkey usage topic. A short while back, we decided to drop support for Firefox 3.0 from new versions of Greasemonkey, somewhat based on the similar work I did back then. But I realize that last graph wasn't very well done, it didn't reveal the 3.x usage clearly. So here's an interactive trend graph that makes it much more obvious:


(Access the raw data and a larger graph at Google Docs.)

It turns out that Firefox 3.5 is even less used than 3.0, both well under 5%. On the other hand, as mentioned, 3.6 is still 25% of usage. It may well mean that we drop 3.5 support and take advantage of some of the behind-the-scenes things available only in 3.6 and higher very soon.

P.S. There's also some graphs, by major version, and minor version within 0.9, of Greasemonkey usage.

Nerd alert: To make this graph, I started with the AMO statistics, and passed it through a python script to clean up and combine the (patch level) versions. By hand, I rearranged the data into a 7-day moving average for the versions I was interested in: 3.0 and higher.

11 comments:

Anonymous said...

PLEASE, make a Firefox version 8 compatible Greasemonkey!

Anonymous said...

it's all greek to me.

Anonymous said...

I would have stayed with Firefox 3.0, but first Pogo (which I didn't care much about) then MySpace REQUIRED that I upgrade in order to even sign in, so I had to bite-the-bullet and upgrade. So now I'm using Firefox 3.6 and I'll stay there until I'm required to upgrade by several sites I just don't want to do without. :) Thank you for creating Greasemonkey.

Anonymous said...

GreaseMonkey 0.9.8 does NOT work in Firefox 3.5. Existing user scripts are not loaded at all.

Anonymous said...

@08:10

Yep :(

Me too, does't work and i have this when i want install viewtube for exemple:

Script could not be installed TypeError: this._initScriptDir is not a function


Debian Squeeze

Anonymous said...

also dont compatible with 3.6.18....

Anonymous said...

Where's the legend? Which version is which color?

Anonymous said...

Isn't there any mecanism to prevent users using old Firefox to automatically update to the new (uncompatible) version?

I'm using Firefox 3.5 (Iceweasel) on Debian Lenny (cannot upgrade to Squeeze now -- some issues remais to be solved) and I was surprised that after an automatic update GM stopped to work completely ("this._initScriptDir is not a function").

Not nice.

Peter said...

I don't know if you read the comments all that often but I would like to humbly request a mobile version of the add-on. It would really be sooo great to be able to use userscripts in Firefox on one's phone etc. ^_^
Anyway, thanks for a GREAT add-on!

Anonymous said...

why can not I run the scrip of gr
easemonkey?

Anonymous said...

Huh? Why would anyone still be using FF 3? We're up to v7 now.

 
国产野外无码理论片在线观看_国产亚洲中文日本不卡二区_国产亚洲欧美在线观看一区